To Attach and Detach External References — GstarCAD 2027


To Attach and Detach External References

GstarCAD 2027 · Command Reference

To Attach an Xref

  1. Click Insert tab > Reference panel > Attach in the ribbon.
  2. The Select Reference File dialog box is displayed, select one or more files you want to attach and then click Open.
  3. In the Attach External Reference dialog box, under Reference Type panel, select Attachment.
  4. Specify the Scale,  Insertion Point and Rotation angle. Click Specify On-Screen to use the pointing device. Attachment includes all nested xrefs.
  5. Click OK to complete the command.

To Attach or Overlay an Xref Using Design Center

  1. Click Tools > Palettes > Design Center on the main menu.
  2. In the content area or in the Find dialog box, locate the DWG reference you want to attach or overlay.
  3. Right-click the DWG reference and choose Attach as Xref.
  4. The Attach external Reference dialog box is displayed, under Reference Type, select Attachment or Overlay. Enter values for Scale, Insertion Point and Rotation, or click Specify On-Screen to use the pointing device.
  5. Click OK to complete the command.

To Detach Xrefs

  1. Click Tools > Palettes > External References on the main menu.
  2. In the External Reference palette, select a DWG reference.
  3. Right-click the selected DWG reference and select Detach from the shortcut menu.

To View Referenced Files by Type

  1. Click Insert tab > Reference panel > dialog box launcher in the ribbon.
  2. Click the List View button in the File References of the External Reference palette.
  3. The attached referenced files are sorted by type in the list view.

Other versions with matching text

2023 · 2024 · 2025 · 2026



Article ID: 6104
Created: September 26, 2026
Last Updated: September 26, 2026
Author: kbadmin

Online URL: https://kb.gstarcad.com.my/article/to-attach-and-detach-external-references-gstarcad-2027-6104.html