Skip to Content

To Copy Objects — GstarCAD 2027

To Copy Objects

GstarCAD 2027 · Command Reference

To Copy an Object Using Two Points

  1. Click Modify > Copy on the main menu.
  2. Select objects you want to copy and press Enter.
  3. Specify the base point for the copy.
  4. Specify the second point. The objects you selected are copied to a new location determined by the distance and direction between the first and second points.

To Copy an Object Using a Displacement

  1. Click Modify > Copy on the main menu.
  2. Select objects you want to copy and press Enter.
  3. Enter the displacement in the form of a Cartesian, polar, cylindrical, or spherical coordinate value. Do not include the @ sign, because a relative coordinate is assumed.

To Create Multiple Copies

By default is the COPY command automatically repeated and you can press ENTER to exit the command. If you want to alter the default, do it via the COPYMODE system variable.

To Copy and Paste

  1. Click Edit > Copy on the main menu or press CTRL+C.
  2. Select objects to copy and press Enter.
  3. You can use one of the following commands to paste the objects:
  • Click Edit > Paste on the main menu or press CTRL+V.
  • Click Edit > Paste as Block on the main menu or press CTRL+SHIFT+V.
  • Click Edit > Paste to Original Coordinates on the main menu.
  1. Follow the command prompts.

To Copy and Paste with Base Point

  1. Click Edit > Copy with Base Point on the main menu or press CTRL+SHIFT+C or enter the COPYBASE command.
  2. Specify the base point.
  3. Select objects you want to copy and press Enter.
  4. You can use one of the following commands to paste the objects:
  • Click Edit > Paste on the main menu or press CTRL+V.
  • Click Edit > Paste as Block on the main menu or press CTRL+SHIFT+V.
  • Click Edit > Paste to Original Coordinates on the main menu.

Other versions with matching text

2023 · 2024 · 2025 · 2026