# ATTACH Command
[GstarCAD 2027](Help%20System/GSTARCAD/2027/Index.md) → [Commands](Help%20System/GSTARCAD/2027/Commands/(Commands).md)
**Function Description:**
This command is used to insert external references, raster images or underlays (DWF, DWFx, PDF or DGN files) or point clouds (RCP and RCS files) to the current drawing.
**Command Access:**
> **Icon:** 
> **Menu:** File > Attach
> **Ribbon:** Insert > Reference > Attach
> **Toolbar:** Insert > Attach
> **Command:** ATTACH
> **Alias:** AT
**Command Prompts: /**
The Select Reference File dialog box is displayed.

---
**Related References:**
- [Commands about Underlays (GstarCAD 2026)](../../2026/Commands/Commands%20about%20Underlays.md)
**Related Tasks:**
- [To Attach and Detach External Reference (GstarCAD 2026)](../../2026/Commands/To%20Attach%20and%20Detach%20External%20References.md)
- [To Attach and Detach Raster Images (GstarCAD 2026)](../../2026/Commands/To%20Attach%20and%20Detach%20Raster%20Images.md)
---
[Original help](https://www.gstarcad.net/help/GstarCAD_2027_en-US/detail/commandReferences/ATTACH.html) · © Gstarsoft Co., Ltd.