# ATTACH Command [GstarCAD 2027](Help%20System/GSTARCAD/2027/Index.md) → [Commands](Help%20System/GSTARCAD/2027/Commands/(Commands).md) → [A](Help%20System/GSTARCAD/2027/Commands/A/(A).md) ## Function Description: This command is used to insert external references, raster images or underlays (DWF, DWFx, PDF or DGN files) or point clouds (RCP and RCS files) to the current drawing. ## Command Access: > **Icon:** ![](Help%20System/GSTARCAD/2027/assets/cda037394ef79093d59ea493001bb18fa27b896a8a29642094c4c65db1bc42ff.png) > **Menu:** File > Attach > **Ribbon:** Insert > Reference > Attach > **Toolbar:** Insert > Attach > **Command:** ATTACH > **Alias:** AT **Command Prompts: /** The Select Reference File dialog box is displayed. ![](Help%20System/GSTARCAD/2027/assets/d6cc564d01acfb24b200dbd700e24f821e3f3793423073c80381864073d936d9.jpg) --- **Related References:** - [Commands about Underlays (GstarCAD 2026)](../../../2026/Commands/00%20Command%20Groups/Commands%20about%20Underlays.md) **Related Tasks:** - [To Attach and Detach External Reference (GstarCAD 2026)](../../../2026/Commands/01%20Procedures/To%20Attach%20and%20Detach%20External%20References.md) - [To Attach and Detach Raster Images (GstarCAD 2026)](../../../2026/Commands/01%20Procedures/To%20Attach%20and%20Detach%20Raster%20Images.md) --- [Original help](https://www.gstarcad.net/help/GstarCAD_2027_en-US/detail/commandReferences_A/ATTACH.html) · © Gstarsoft Co., Ltd.