# 3DMESH Command [GstarCAD 2027](Help%20System/GSTARCAD/2027/Index.md) → [Commands](Help%20System/GSTARCAD/2027/Commands/(Commands).md) → [3D](Help%20System/GSTARCAD/2027/Commands/3D/(3D).md) ## Function Description: This command is used to create polygonal mesh in any styles. The density of the mesh controls number of mosaic surfaces. The mesh is defined by M×N vertices of rectangles, this is similar to row and column of grid. It is a traditional way to create mesh by the 3DMESH command and designed for program operation rather than manual operation. ## Command Access: > **Icon:** ![](Help%20System/GSTARCAD/2027/assets/59d6a66af55d5d26293ab1188e2d1c75e353a30b7a480e0af9a3788cef72ba1b.png) > **Menu:** Draw > Modeling > Meshes > 3D Mesh > **Ribbon:** 3D > Mesh > 3D Mesh > **Toolbar:** / > **Command:** 3DMESH > **Alias:** / ## Command Prompts: ``` Enter size of mesh in M direction: Enter size of mesh in N direction: Specify location for vertex (0, 0): ``` ## **Size of mesh in M direction** Specifies the size of mesh in M direction, it is a value between 2 and 256. ## **Size of mesh in N direction** Specifies the size of mesh in N direction, it is a value between 2 and 256. The value of M×N must be equal to the specified vertex number. ## **Location for vertex (0, 0)** Specifies coordinates for each vertex. Users can enter two dimension or three dimension coordinates. The location for each vertex is determined by the M and N (M is the subscript of row and N is the subscript of column). Defines vertex coordinate beginning with (0, 0) and firstly specifies the vertex coordinate with M, and then specifies M+1. The distance of vertex can be any value and directions of M and N are determined by their coordinate locations. Meshes created by the 3DMESH command are open in M and N direction, users can use PEDIT command to close them. ![](Help%20System/GSTARCAD/2027/assets/d735cd17e52d5bc615358c25425022372d48e571e40133f455d93c5ad96be56f.gif) --- **Related References:** - [Commands about Creating a Mesh (GstarCAD 2026)](../../../2026/Commands/00%20Command%20Groups/Commands%20about%20Creating%20a%20Mesh.md) **Related Tasks:** - [To Create a Rectangular Mesh (GstarCAD 2026)](../../../2026/Commands/01%20Procedures/To%20Create%20a%20Rectangular%20Mesh.md) --- [Original help](https://www.gstarcad.net/help/GstarCAD_2027_en-US/detail/commandReferences_3D/3DMESH.html) · © Gstarsoft Co., Ltd.