# ATTACH Command [GstarCAD 2025](Help%20System/GSTARCAD/2025/Index.md) → [Commands](Help%20System/GSTARCAD/2025/Commands/(Commands).md) **Function Description:** This command is used to insert external references, raster images or underlays (DWF, DWFx, PDF or DGN files) or point clouds (RCP and RCS files) to the current drawing. **Command Access:** > **Icon:** ![](Help%20System/GSTARCAD/2025/assets/cda037394ef79093d59ea493001bb18fa27b896a8a29642094c4c65db1bc42ff.png) > **Menu:** File > Attach > **Ribbon:** Insert > Reference > Attach > **Toolbar:** Insert > Attach > **Command:** ATTACH > **Alias:** AT **Command Prompts: /** The Select Reference File dialog box is displayed. ![](Help%20System/GSTARCAD/2025/assets/d6cc564d01acfb24b200dbd700e24f821e3f3793423073c80381864073d936d9.jpg) --- **Related References:** - [Commands about Underlays](Help%20System/GSTARCAD/2025/Commands/Commands%20about%20Underlays.md) **Related Tasks:** - [To Attach and Detach External Reference](Help%20System/GSTARCAD/2025/Commands/To%20Attach%20and%20Detach%20External%20Reference.md) - [To Attach and Detach Raster Images](Help%20System/GSTARCAD/2025/Commands/To%20Attach%20and%20Detach%20Raster%20Images.md) --- [Original help](https://www.gstarcad.net/help/GstarCAD_2025_en-US/detail/commandReferences/ATTACH.html) · © Gstarsoft Co., Ltd.