# ATTACH Command
[GstarCAD 2023](Help%20System/GSTARCAD/2023/Index.md) → [Commands](Help%20System/GSTARCAD/2023/Commands/(Commands).md) → [A](Help%20System/GSTARCAD/2023/Commands/A/(A).md)
## Function Description:
This command is used to insert external references, raster images or underlays (DWF, DWFx, PDF or DGN files) to the current drawing.
## Command Access:
> **Icon:** 
> **Menu:** File > Attach
> **Ribbon:** Insert > Reference > Attach
> **Toolbar:** Insert > Attach
> **Command:** ATTACH
> **Alias:** AT
**Command Prompts: /**
The Select Reference File dialog box is displayed.

---
**Related References:**
- [Commands about Underlays](Help%20System/GSTARCAD/2023/Commands/00%20Command%20Groups/Commands%20about%20Underlays.md)
**Related Tasks:**
- [To Attach and Detach External Reference](Help%20System/GSTARCAD/2023/Commands/01%20Procedures/To%20Attach%20and%20Detach%20External%20Reference.md)
- [To Attach and Detach Raster Images](Help%20System/GSTARCAD/2023/Commands/01%20Procedures/To%20Attach%20and%20Detach%20Raster%20Images.md)
---
[Original help](https://www.gstarcad.net/help/GstarCAD_2023_en-US/detail/commandReferences/ATTACH.html) · © Gstarsoft Co., Ltd.